Website Monitors might be triggering false alerts

Incident Report for IsDown

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 14:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 12:35 UTC

Update

We are continuing to investigate this issue.
Posted Mar 25, 2026 - 07:14 UTC

Investigating

The issue seems to be with our North America server that runs the checks. We're still trying to understand the root cause.
Posted Mar 24, 2026 - 23:50 UTC

Monitoring

We've made some changes and will monitor the fix for the next few hours
Posted Mar 24, 2026 - 20:37 UTC

Investigating

We're getting reports that website monitors might be triggering down alerts. We're investigating possible causes.
Posted Mar 24, 2026 - 20:16 UTC
This incident affected: Monitors ( Websites ).