Issues with status page provider

Incident Report for IsDown

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:04 UTC

Monitoring

There's an ongoing AWS outage that affects a great part of the internet, and especially one big status page provider where we collect the data.

We're going through the queue as it seems to be recovering.

Sorry for the delay.
Posted Oct 20, 2025 - 09:47 UTC
This incident affected: Monitors ( Third-party services ).